Is midi fx still working?

I tried to use midi effects and it’s not working.

Here is what I did :

  1. Create a midi track.
  2. Input : All midi inputs
  3. FX : MIDI Polysher (free midi transposer)
  4. Output : Test Note (just for testing, I tried also with many midi instruments)
  5. Make sure that the input to Test Note is just the midi track I just added in step 1)

It seems that the FX has no effect!!! I also tried with Chordz (a free vst for creatinf chords from single note) but with no success.

Am I missing something? I have the ALK2 full version.

I can’t get it to work either.

Same here. Tried it with the super basic Insert Piz Here midi effects and nothing happens. I’ve basically resorted to processing MIDI in another DAW (Reaper) and sending it back. Not ideal, but whatcha gonna do?

I was able to get it to work using Bome MIDI Translator.
The translator allows me to create a virtual MIDI In and MIDI Out connection (called BM1). I rout the MIDI In of BM1 to the MIDI Out of BM1.

In ALK2, Using MIDI track, I use my keyboard as the MIDI Input,
select something in the FX, then Output to the virtual MIDI connection. (BM1)

Then I create an instrument track in ALK2 and use the virtual MIDI track (BM1) as the MIDI Input and Voila! The FX I used in the MIDI track affects the sound in the Instrument track.

It looks to me like a patch. Alk2 should be capable of doing this directly. Since others experience the same problem I guess this is a bug and not just me not doing something wrong. Please zenAud.io fix this bug. It’s a big part of your software that is not working! Thank you.

Made it work using free (for non commercial use) Springbeats virtual MIDI Cable.

Midi TRACK : Midi keyboard -> Midi fx -> Virtual midi cable
Instrument track : Virtual midi cable -> Midi instrument -> Audio output